Lab 6-2 - Configuring a Floating Static Route

Real World Application & Core Knowledge

In the previous lab you’ve studied the basics of static routing and how it operates to ensure network reachability. This lab will give you another building block to build that fancy house with now that you have a foundation.

A Floating static route is a route that has a higher administrative distance then the current route in a routing table. Think of how a router works for a second; The routes that have a lower administrative distance number will be the ones installed into the routing table whereas higher AD numbers will not.

Looking back to the Lab 6-1 topology, R1 has a single link to R2 via frame-relay point-to-point sub-interface. Now add a point-to-point T1 link between R1 and R2 and this gives you the ability to have redundancy and potentially load balancing if you wanted but however this link you’ve newly installed is dedicated for backup only and you have to pay based on per MB bandwidth which is very expensive. So ideally you’d want to use your primary frame-relay link when its active but your point-to-point T1 when the primary link fails.

So you have the idea in your head but how do get this current proposed idea to operate with the current routing infrastructure? The answer is a floating route.

To create floating static route(s) you will create identical routes that already exist which go to R2 through the main frame-relay link to traverse the point to point link which have a higher administrative distance so as long as Serial0/0 is up traffic will take that path but if Serial0/0 fails the router will re-converge and traffic will transit the link Serial0/1 to get to R2.

In the real world floating static routes are commonly used as an “emergency default route” which will be discussed in the next but; but in laymen terms, when a dynamic routing process neighbor relationship fails for whatever reason all the routes get removed which includes the default route learned via the dynamic routing process. If and when this incident occurs in a network the device will automatically inject the static route as it would be next in line with the highest administrative distance.

Configuring a floating static route is very easy and its done by a command you already know; ip route n.n.n.n s.s.s.s nh.nh.nh.nh but you add a number to the end of the command ranging between 1-255 whereas 255 is “unreachable”. Any route given the administrative distance of 255 WILL NOT be installed in the routing table under any circumstances. Keep in mind the default administrative distance of a static route is 1.

In this lab you’ll use Lab 6-1′s topology but add an additional link between R1 and R2 to create a backup traffic path for R1 to reach R2 and R3. Topology shown below;

Familiarize yourself with the following new command;

Command Description
ip route n.n.n.n s.s.s.s nh.nh.nh.nh # This command is executed from global configuration and is the same command used to configure a static route but statically sets the administrative distance following the next hop.

Lab Prerequisites

  • If you are using GNS3 than load the Free CCNA Workbook GNS3 topology than start devices; R1, R2 and R3.
  • Establish a console session with devices R1, R2 and R3 than configure the devices respected hostname(s).
  • lLoad the initial configurations provided below by copying the config from the textbox and pasting it into the respected routers console.

Lab Objectives

  • Configure the new point-to-point link between R1 and R2 using the subnet 10.62.21.0/30 and ppp encapsulation. Verify that the link is up using ping.
  • Create two floating static routes with the administrative distance of 200 for 10.55.20.0/24 and 10.55.30.0/24 pointing towards R2′s backup link IP address.
  • Create a floating route on R2 with the administrative distance of 200 for 10.55.10.0/24 pointing towards R1′s backup link IP address.
  • Shutdown Serial0/0 on R1 and Serial0/0.221 on R2 to simulate a link outage and verify IP connectivity by tracing to the 10.55.30.0/24 network from the 10.55.10.0/24 network.

Lab Instruction

Objective 1. – Configure the new point-to-point link between R1 and R2 using the subnet 10.62.21.0/30 and ppp encapsulation. Verify that the link is up using ping.

R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface Serial0/1
R1(config-if)#ip address 10.62.21.1 255.255.255.252
R1(config-if)#encapsulation ppp
R1(config-if)#no shut
R1(config-if)#end
R1#
R2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#interface serial0/1
R2(config-if)#ip add 10.62.21.2 255.255.255.252
R2(config-if)#encapsulation ppp
R2(config-if)#no shut
R2(config-if)#end
R2#ping 10.62.21.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.62.21.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/42/60 ms
R2#

Objective 2. – Create two floating static routes with the administrative distance of 200 for 10.55.20.0/24 and 10.55.30.0/24 pointing towards R2′s backup link IP address.

Under the core knowledge section you learned the concepts of floating routes and how to configure them. The commands are the same as a static route except specifying an administrative distance as shown below;

R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#ip route 10.55.20.0 255.255.255.0 10.62.21.2 200
R1(config)#ip route 10.55.30.0 255.255.255.0 10.62.21.2 200
R1(config)#end
R1#

Objective 3. – Create a floating route on R2 with the administrative distance of 200 for 10.55.10.0/24 pointing towards R1′s backup link IP address.

R2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#ip route 10.55.10.0 255.255.255.0 10.62.21.1 200
R2(config)#end
R2#

Objective 4. – Shutdown Serial0/0.221 on R2 and Serial0/0 on R1 and to simulate a link outage and verify IP connectivity by tracing to the 10.55.30.0/24 network from the 10.55.10.0/24 network.

R2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#interface Serial0/0.221
R2(config-subif)#shutdown
R2(config-subif)#end
R2#
R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface serial0/0
R1(config-if)#shutdown
R1(config-if)#end
R1#
%SYS-5-CONFIG_I: Configured from console by console
%LINK-5-CHANGED: Interface Serial0/0, changed state to
administratively down
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed
state to down 
R1#traceroute 10.55.30.1 source Lo0

Type escape sequence to abort.
Tracing the route to 10.55.30.1

  1 10.62.21.2 152 msec 52 msec 44 msec
  2 10.62.23.2 188 msec 240 msec 217 msec
R1#

As you can see from the traceroute shown above, traffic sourced from 10.55.10.0/24 destined towards 10.55.30.1 will take the point to point link as you see that the first hop in the transit path is 10.62.21.2 which is R2′s Serial0/1 interface.